PHP7在Linux下开启配置使用MongoDB

3,499次阅读
12 条评论

共计 603 个字符,预计需要花费 2 分钟才能阅读完成。

前言

近段时间在项目中有需求用到了 MogonDB,实际项目是采用的 Java,但是为了方便快速的实现 Demo,我就采用了 PHP7.1 来进行实现,由于官方的 PHP 没有 MongoDB 的依赖包,所以我们需要手动来进行编译安装开启 MongoDB。

正文

首先我们需要先下载 MongoDB 的依赖包,依赖包大家可以到 https://pecl.php.net/package/mongodb 上进行查找,这里我们使用 1.5.3 的版本进行操作。

wget https://pecl.php.net/get/mongodb-1.5.3.tgz # 下载依赖包
tar -zxvf mongodb-1.5.3.tgz # 解压依赖包
cd mongodb-1.5.3

上面我们已经完成了依赖包的下载与解压,接下来我们再进行侦测环境以及生成配置文件和编译安装。

phpize
./configure --with-php-config=/usr/bin/php7/php-config
make && make install # 编译并安装

到这一步我们就已经完成了 MongoDB 的依赖包的编译安装,接下来我们再 php.ini 中引入重载配置即可。

extension=mongo.so # 将此配置添加到 php.ini 中即可

尾记

其实使用 PHP 的来完成一些快速开发还是挺快的,在一定的情况下不用多余的操作就可以保证其开发及运行效率,SO… 我再考虑以后要不要多多使用 PHP 了,拜了个拜。

正文完
使用官方微信小程序体验更多功能
post-qrcode
 9
憧憬Licoy
版权声明:本站原创文章,由 憧憬Licoy 2019-03-12发表,共计603字。
转载说明:除特殊说明外本站文章皆由CC-4.0协议发布,转载请注明出处。
评论(12 条评论)
浪子丶刘少 评论达人 LV.1
2019-04-02 22:51:16 回复

大佬,受教了,学习观摩下下~~

 Windows  Chrome  中国北京北京市联通
西西 评论达人 LV.1
2019-03-30 14:02:16 回复

我去饿

 Windows  Chrome  中国四川省广安市移动
    憧憬Licoy 博主
    2019-04-01 09:06:42 回复

    @西西 :?: :?:

     Windows  Chrome
      西西 评论达人 LV.1
      2019-04-04 12:35:59 回复

      @憧憬Licoy 博主我想问一下,多层级回复在页面上显示怎么实现的?你是用的前端渲染吗?JSP怎么实现因为不知道具体有多少回复层级 。

       Windows  Chrome  中国四川省广安市移动
      西西 评论达人 LV.1
      2019-04-04 14:15:23 回复

      @憧憬Licoy EL表达式 用不了递归。谢谢博主! :mrgreen:

       Windows  Chrome  中国四川省广安市移动
紫书海 评论达人 LV.1
2019-03-21 11:53:02 回复

如此好文章一定要留下名啊

 Windows  Firefox  中国江西省九江市电信
老部落 评论达人 LV.1
2019-03-20 08:55:55 回复

朋友 交换链接吗

 Windows  Chrome  中国江苏省苏州市电信
丘八阅读网 评论达人 LV.1
2019-03-19 14:22:40 回复

文章不错,非常喜欢

 Windows  Firefox  中国江西省九江市电信